RALLY! Education Online Requirements

RALLY! Education Online Requirements

RALLY! Education Online products are designed to work on any browser connected to the internet. All programs and data are housed on RALLY!’s server. There are no local requirements other than those required to access the internet.

DISCLAIMER: Although RALLY!’s online products work with all computers and internet browsers, there may be performance issues with older systems. It is highly recommended that the latest versions of operating systems and browsers be used. For Windows computers, it is preferable to upgrade to Windows 10 and use browsers such has Chrome or FireFox.

NOTE: Microsoft is no longer supporting any version of Internet Explorer. Also, Windows 7 and many earlier versions of Internet Explorer also have known security vulnerabilities that could be exploited.